Newsworthy
User Rating:  / 4
PoorBest 

WPS has updated all EDI forms to include a version number at the bottom of each form. Effective March 1, 2013, the only forms accepted by WPS will be the forms that include a version number on the bottom of the form. If you are currently enrolled, a new form is not required.

 

The new EDI forms can be downloaded from the following website: http://www.wpsic.com/edi/files/medb_enroll.pdf